"The VST2 plug-in is damaged and can't be opened" (macOS)

  • Live Versions: 10.1.2 and later
  • Operating System: macOS Mojave 10.14 and Catalina 10.15

Due to new security requirements in macOS, certain outdated or cracked plug-ins can crash Live 10.1.2 and Live 10.1.3. The crashes may occur when loading sets, scanning plug-ins or loading the affected plug-ins from the browser. This issue only affects macOS users on Mojave 10.14 and Catalina 10.15 running these particular plug-ins. 

Live 10.1.4 (and later) shouldn't crash, however Live displays the error message "The VST2 plug-in is damaged and can't be opened" when trying to open affected plug-ins. 

damaged.png

Solution

Download and install the very latest, official release of the affected plug-in from the manufacturer's website. Make sure that the plug-in is macOS Catalina compliant where possible.

As this issue primarily affects VST plug-ins, you could switch to the AU version instead. Otherwise, remove the affected plug-ins from your plug-in folder.

Live 10.1.1 macOS download links

In case this doesn't solve the issue, you can temporarily install Live 10.1.1 to try and open those sets. Then we recommend that you freeze and flatten the tracks containing those plug-ins.

Note: Rename your existing installation (in Applications → Right click "Rename" → Eg. Ableton Live Suite Current Version). Then install 10.1.1 and turn off automatic downloads (Preferences → Licenses Maintenance).