Live 10 compatibility with macOS 10.15 Catalina

  • Live Versions: 10.1.2 and later
  • Operating System: macOS 10.15 Catalina

When is the release date of macOS 10.15 Catalina?

macOS 10.15 Catalina is out now. It was released on 7th October 2019.

Is Live 10 compatible?

As of version 10.1.2, Live is fully compatible with Catalina. Live 10.1.1 and all earlier versions of Live 10 are not compatible with Catalina. See the Live 10 release notes for all the new features and bugfixes in the latest version.

Should I update to Catalina now?

No, we highly recommend not to update your OS to Catalina yet. Although Live 10 is fully compatible, it's very possible that some of your third party plug-ins, hardware drivers and other software programs are not yet supported on Catalina. Once you've confirmed that all of your dependent software and drivers are Catalina ready, then you can decide to update. But make sure to create a time machine backup before updating so that you can roll-back to your previous operating system if needed. Also make sure not to update if you are working on time-critical projects.

These articles from CDM describe in detail what impact Catalina has on your software: 

To quote CDM: What’s impacted:

  • DAWs and other software using plug-ins: Requires updates to work.
  • Drivers: Installation and operation requires update to work.
  • 32-bit software, software that accesses 32-bit libraries: Incompatible. Cannot be used past macOS Mojave.
  • Software using legacy video libraries: Incompatible. Cannot be used past macOS Mojave.
  • Plug-ins: May require update for full compatibility – but may run inside updated DAWs, and will install if the user overrides OS’ installer requirements.
  • Hardware: If a driver is required for operation, you’ll need an updated driver and installer. Driverless (class-compliant) audio and MIDI gear is unaffected.

Is Live 9 compatible with Catalina?

No. Live 9 is not compatible and will not be updated for compatibility. See: Live 9 is not compatible with macOS 10.15 Catalina.

I've updated to Catalina and now some of my sets won't load. What do I do?

Update to Live 10.1.2 (or later), then try again. If it's still not working then it's possible that your sets contain plug-ins which haven't yet been updated. Check the manufacturer's website for Catalina-ready updates for those plug-ins (if available).

I've updated to Catalina but my MP3 files and video won't work in Live. What do I do?

If you're running any earlier version of Live 10 you won't be able to decode compressed audio file (MP3, M4A etc), or work with video on Catalina. Update to Live 10.1.2 (or later)We've replaced the outdated framework (QTKit) with a new one (AVFoundation) and this should resolve the issue. See: MP3 decoding, video playback and export in Live 10.1.2 and later (macOS).

Nothing is working. What do I do?

See this third party article on how to roll-back to your previous operating system. If you're not able to or have further issues, please contact technical support.

Further Reading

macOS Compatibility with Live.