"Ableton.app" is not optimised for your Mac and needs to be updated

  • Live Versions: 9 - 10.1.1
  • Operating System: 10.13.4 and later

Not_optimised.png

Background

Starting with macOS High Sierra 10.13.4, apps that have not been updated to use 64-bit processes produce a one-time alert when opened. This gives users advance notice that they are running 32-bit software, which will not be compatible with macOS in the future. In macOS Mojave, this alert appears once every 30 days when launching the app.

Live 10

Starting with Live 10.1.2, all 32-bit components have been removed from Live and this error message does not appear when launched. If you haven't already updated, make sure to install the latest version of Live 10.

Live 9

If you receive this notification when starting Live 9, just click "OK". It doesn't affect the functionality of Live in any way, nor does it pose any security or stability risks.

Further Reading

Full details on Apple's website: 32-bit app compatibility with macOS High Sierra 10.13.4 and later