Live 9.2 Legacy OS Compatibility

  • Live Versions: 9.2 and later
  • Operating System: OSX 10.5, OSX 10.6, Windows Vista, Windows XP

From Live version 9.2 and later, Live will not be compatible with the following operating systems:

  • OSX 10.5
  • OSX 10.6
  • Windows XP
  • Windows Vista

In order to continue improving Live, updates to the program architecture are required. This makes the process of maintaining legacy operating systems costly and impractical. 

How do I know if I am on a legacy operating system? 

First you should make sure, which Operating System you are currently running. 

What does that mean for me?

Users on these unsupported operating systems will be unable to install Live 9.2 or later on their computer. They can find download links to the Live 9.1.10 installers in our download archive

Should a user have automatic updates activated, Live will continue to update until version 9.1.10, where updates will be deactivated, and the program will remain on this version.

Legacy OS Updates deactivated

Legacy OS