Dual Monitor Support

  • Live Versions: All
  • Operating System: All

Live offers dual monitor support:

When working with two monitors at the same time, you can see the Session/Arrangement and Clip/Device Views simultaneously, or dedicate a single monitor to detailed MIDI clip editing.

If there is only one large monitor available, the second window can be used to work with different views at the same time.

The second window can be enabled from View Menu → Second Window.

When using the Second Window option:

  • Live's Browser and the Info View will be shown in Live's main window. You can of course drag the main window to any of your monitors.
  • Live can't show the Clip View or the Device View on both windows at the same time. That means that Clip View will be on one display while Device View is on the other. They can be swapped between each window by pressing Shift + Tab.
  • "Show/Hide Detail View" from the View menu will be applied in the window that currently has the focus.
  • The File menu item "Close Window" won't be available if Live's main window has the focus. It will close the second window if this one has the focus. This means that "Close Live Set" option (CTRL / CMD + W) is deactivated when a single window is open. Instead, 'New Live Set' (CTRL / CMD + N) will achieve the same result.