Error message: "Company Support Dir not found" (Mac)

  • Live Versions: 1 - 9
  • Operating System: OS X

There are two main reasons why this error message may be shown while Live is starting:

The most prominent MIDI problem on OSX is caused by a Digidesign MIDI driver which is obviously not fully compatible with later versions of OSX and causes all MIDI applications to hang while trying to initialize this driver. The system's Audio-MIDI-Setup is for example also affected (/Applications/Utilities/).

Incompatible version of a Digidesign MIDI driver

  • Install the latest Pro Tools 10 update, or:
  • Remove the Digidesign MIDI driver DigiDioMidiDriver.plugin from this folder: Macintosh HD/Library/Audio/MIDI Drivers/
  • Please contact Avid to obtain a compatible MIDI driver for your Pro Tools hardware.

Note: Other outdated MIDI drivers can also cause these issues. If there is no Digidesign driver in the MIDI Driver folder, you can delete any other suspect midi drivers.

For further information please refer to the following Avid knowledge base article.

Audio driver problems

  • Open the audio window of the system's Audio-MIDI-Setup.
  • In the left side bar remove the audio devices, by selecting the device and clicking the minus symbol in the lower part of the window. Please note that this only works for certain devices, in many cases the minus symbol is greyed out and the device can't be removed.
  • Re-start Live.
  • If Live launches again, you might re-install drivers for your audio hardware. Please make sure that the drivers are compatible with the operating system of your computer.

audiomidisetup_removedriver_1.jpg__554x371_q85_subsampling-2.jpg

Additional Information

Please contact Ableton Support if none of the solutions listed above work for you.