Accessibility in Live Overview

As of Live 12, Ableton Live supports using assistive technologies such as screen readers on macOS and Windows. While any screen reader software should work, on macOS we test with VoiceOver, and on Windows we test with NVDA, Narrator, and JAWS. 

Getting Started

Keyboard
Accessibility
Audio configuration
Setting up MIDI devices

Exploring Live's UI

Control Bar (Alt/Option + 0)
Session View (Alt/Option + 1)
Arrangement View (Alt/Option + 2)

Arrangement View timeline

How to get around
Adjusting Clip edges
Inserting content
Selecting content
Moving content
Deleting content
Exporting Audio

Clip View (Alt/Option + 3)

Working with MIDI

With notes selected

Working with Audio

Device View (Alt/Option + 4)
Browser (Alt/Option + 5)

Getting Started

Many improvements for keyboard navigation and keyboard workflows have been added. You can find out more about these updates in the Live Manual and the Accessibility in Ableton Live FAQ. Most commands and workflows are accessible via keyboard navigation. 

Additional options that support accessibility include themes with high-contrast variants and preferences in Live > Options > Accessibility, such as "Speak Menu Commands" and "Speak Minimum and Maximum Slider Values.”

Keyboard

The core of Live’s accessibility is its keyboard workflow. Live supports Tab navigation nearly everywhere, and the areas without Tab navigation will be fixed in future releases.

To begin, set up your accessibility Preferences:

  1. Open the Preferences (Control + comma on Windows; Command + comma on macOS). Focus should be on the radio button to select the Display & Input Preferences page. If another button is selected, use the arrow keys.
  2. Use the Tab key to focus the first setting in the page. To change the language, open the pop-up with the Enter key, and navigate the options with the Up/Down Arrows. Making a selection here will prompt you to restart Live in the new language.
    Note: All of Live’s buttons are triggered with the Enter key. The Space key is always used to control transport playback.
  3. Continue Tabbing through the Display & Input Preferences until you find Use Tab Key to Navigate and Wrap Tab Navigation. Make sure they’re both set to “On."
  4. Close the Preferences with the Escape key.

Accessibility

The Options menu (Alt + O on Windows; VO + M, then O with VoiceOver on macOS) has an Accessibility sub-menu. Each option in the Accessibility sub-menu gives you extra control over what information you hear as you move around the software.

We recommend activating all available options when first getting started. We sometimes add more options, so check this sub-menu after updates to see what’s new.

Nearly every bit of Live has help text, and it’s very useful when learning the software. If you’re on Windows, activate the Speak Help Text option to append any available help text to the name of each element. If you’re using VoiceOver on macOS, we recommend that you turn on help text in VoiceOver Utility’s verbosity settings. You can also access help text manually with VO + Shift + H.

Audio configuration

Open Live’s Preferences (Control + comma on Windows, Command + comma on macOS). Focus should be on the radio button for whichever page you last visited in the Preferences. Select Audio and Tab into the Audio page.

Audio setup varies between macOS and Windows. On macOS, Live’s input and output can be connected to any CoreAudio device. You can also select other drivers from the Driver Type pop-up. On Windows, select your preferred driver, for example ASIO4ALL, and manage connected devices via the driver’s own program.

The buttons Configure Inputs and Configure Outputs can be pressed to open up the channel configuration dialogs. These dialogs let you choose which mono and stereo channels are available to use in Live. You can also give names to each channel. The names get used to label routing options around Live.

To ensure you have a working audio output, Tab to the Test Tone option and activate it with Enter. If you hear a tone, then you’re ready to go. If you don’t hear a tone, follow the guide to setting up an audio interface.

Setting up MIDI devices

Live automatically detects connected MIDI devices. Some MIDI controllers also come with scripts to integrate them with Live’s workflows. You can use these devices, but they are not well-integrated with screen readers yet.

The Link, Tempo & MIDI page in the Preferences has a table labeled Control Surfaces with options to configure attached controllers. There are also Inputs and Outputs sections below the table, with more specific options for connected MIDI devices. To learn more, check out the MIDI and Key Remote Control section of the Live manual.To learn more, check out the MIDI and Key Remote Control section of the Live manual.

Exploring Live's UI

Once you’ve activated the relevant accessibility options and set up your audio and MIDI devices, you can explore Live’s UI. Open the Navigate menu (Alt + N on Windows; VO + M, then N with VoiceOver on macOS). Inside Navigate you’ll find all the important navigable locations and their corresponding shortcuts. In certain sections, if you navigate away and then back to a specific section, your focus returns to the last-focused control. In other sections, using the navigation shortcut takes you to a specific piece of that section.

Control Bar (Alt/Option + 0)

The Control Bar consists of project settings, transport controls, mouse/keyboard tools, and status views. Sections are organized by accessible groupings. Tab and Shift+Tab between controls with Help Text turned on in order to learn about each option.

The Control Bar remembers your last-focused control and restores it when returning with the keyboard shortcut.

Session View (Alt/Option + 1)

Session View is Live’s non-linear approach to music making. It consists of four main sub-sections:

  1. Track Headers, a tree-list of the tracks that can be navigated with the Left and Right Arrow keys. The context menu of each track header contains useful commands and their corresponding keyboard shortcuts.
  2. Slots, a keyboard-navigable grid of Clip Slots. Clip Slots can hold audio and MIDI content, which can be copied and pasted with the keyboard. When focused on a Clip Slot in a MIDI track, you can insert an empty MIDI Clip with Control/Command + Shift + M.
    There are slots in the return tracks, but they don’t do anything.
    Launch the selected Clip by pressing Enter. If Live’s transport is running, then the setting in the Control Bar’s Quantization Menu will affect when the Clip begins playing.
  3. Scenes, a list of numbered Scene elements which can be navigated with the Up and Down Arrows. Activating a Scene with the Enter key triggers all Clip slots in the Scene. Scenes form the Y-axis of the Session grid, against the X-axis of the Track Headers.
  4. Mixer Panels, one for each track, contain routing and mixer controls, as well as more specific options. The View menu contains a Mixer Controls sub-menu which lets you customize the visible mixer panel sections.

The Session has two navigation modes. Track Headers, Clip Slots, and Scenes form a grid and can be navigated with Arrow keys. You can skip over the Clip Slots and Scenes using Tab and Shift+Tab.

Mixer Panels are navigated with the Tab and Shift-Tab keys. To quickly jump between tracks, use the Next Neighbor and Previous Neighbor navigation shortcuts (Control + Tab and Control + Shift + Tab on Windows; Opt + Tab and Opt + Shift + Tab on macOS).

Press Escape from anywhere in Session View to focus the selected Track Header(s).

The Control Bar remembers your last-focused control and restores it when returning with the keyboard shortcut.

Arrangement View (Alt/Option + 2)

The Arrangement is a timeline-style view for arranging audio, MIDI and automation over time.

Using keyboard navigation, you can:

  • Move around the timeline
  • From the timeline, Shift-Tab through the loop markers and Tab to Locators
  • If you tab forward from the timeline you can Set or Delete locator button
  • Use buttons to jump to the next or previous locator
  • Use checkboxes to control Automation mode and Lock Envelopes
  • Navigate vertical list of Track Headers with Up/Down Arrow keys
  • Navigate Mixer panels with (Shift+)Tab and (Shift+)Control/Opt+Tab

Tabbing from the end of the Mixer panel takes you to a group of controls governing waveform zoom and track width/height.

Arrangement View timeline

How to get around

  • Up/Down Arrow keys switch between tracks.
  • Left/Right Arrow keys move in time according to the current grid setting.
  • Plus and Minus keys widen or narrow the grid resolution.
  • In a content lane, Control + Left/Right on Windows, and Opt + Left/Right on macOS, move to the previous/next Clip edge or locator.

Adjusting Clip edges

  • Press Enter when the insert marker intersects with a Clip edge to begin moving the Clip edge. When you’ve finished, press Enter again to stop moving the Clip edge. You can also press Escape while moving the Clip edge to cancel the change.

Inserting content

  • Content can be copied from the Browser or from elsewhere on your computer and pasted into the Arrangement timeline.

Selecting content

  • Hold Shift while moving with the arrow keys (along with other modifiers) to select content in the timeline.

Moving content

  • By default, selected content will be moved with the Left and Right Arrow keys.
  • You can cut, copy, duplicate, and paste selected content using keyboard shortcuts (Control/Command + X, Control/Command + C, Control/Command + D, Control/Command+V).

Deleting content

  • Press Backspace or Delete to delete selected content in the Arrangement timeline.

Exporting Audio

  • Select a region in the timeline and press [Control/Command+Shift + R] to open the audio export dialog. By default, the rendered track is the Main audio track.

Future updates to the Knowledge Base will include more information about how to work in Arrangement View.

Note: Automation and audio Clip edge fades are not currently supported for screen reader use.

Clip View (Alt/Option + 3)

The Clip view shows the currently selected Clip or multiple selected Clips in the focused main view. To work with a Clip, select it in the Session view, or Arrangement view.

The Clip view has two main sections: the Clip Properties (Alt/Option + Shift + P) and the Clip Content Editor (Alt/Option + 3).

Clip Properties let you control and manipulate various aspects of the selected Clip or Clips. The help text has a lot of useful information about each control in this section.

In the Clip Content Editor, Plus and Minus keys widen or narrow the grid resolution. Left/Right Arrow keys move the insert marker in time, according to the current grid resolution.

Working with MIDI

  • We recommend that you turn on the MIDI Editor Note Preview setting the Options menu. This lets you listen to notes when selecting them in the MIDI Note Editor timeline.
  • Control/Option + Left/Right Arrows move the insert marker to the previous/next note boundary.
  • Make a time selection by holding Shift and use the Arrow keys (optionally with modifiers).
  • With a time selection that includes MIDI notes, pressing Enter/Return selects the notes.

With notes selected

  • Modifying notes
    • Up/Down Arrow keys transpose the selected notes according to the set scale.
    • Left/Right Arrow keys move the selected notes in time according to the current grid resolution.
    • Shift + Up/Down Arrow keys transpose the selected notes by one octave.
    • Shift + Left/Right Arrow keys shorten or lengthen the selected notes by the current grid resolution.
    • Control/Command + Up/Down Arrow keys adjust velocity of the selected notes
    • Control/Command + Alt/Option + Up/Down Arrow keys adjust probability of the selected notes
  • Navigating notes
    • Control/Option + Up/Down Arrow keys jump to the next/previous note.
    • Control/Option + Left/Right Arrow keys jump to the previous/next note of the same pitch.
    • Hold Shift to extend selection while using the above shortcuts.

Working with Audio

  • Control/Option + Left/Right Arrow keys move the insert marker between Warp Markers and Transients.
  • Hold Shift to extend selection while using the above shortcuts.
  • Press Control/Command + I to insert and select a Warp marker at the current position.

Note: Automation, Modulation and MPE are not currently supported for screen reader use.

Device View (Alt/Option + 4)

Shows the list of devices loaded on the currently highlighted track. MIDI tracks can have MIDI Effects, Instruments, and Audio Effects. Audio, Group and Return tracks can have Audio Effects.

Each loaded device is represented to screen readers as a group. You can move between devices with the Arrow keys; cut, copy, duplicate, and paste them with keyboard shortcuts; and delete them with the Delete/Backspace key.

With a device selected, the Tab and Shift + Tab keys will navigate into the device.

Note: Most devices have some basic accessibility support, but more advanced devices haven’t been optimized for screen readers yet.

Browser (Alt/Option + 5)

Consists of three main sections: the Search bar, the Sidebar and the Content list. The Search bar can be focused directly from anywhere in Live with Control/Command + F. This updates the Sidebar selection to the All label, which contains all content in the Browser. Tab from the Search bar to focus the Sidebar. Down Arrow key from the Search bar moves focus to the Content list.

The Sidebar is a list of labels which can be single-selected with the up/down Arrow keys. The selected label controls what is shown in the Content list. Tab and the Right Arrow key move focus to the Content list.

The Content list is a tree-like list containing both files and folders. Devices that contain presets are represented as folders. Multi-selection of certain types of content is possible with Shift + Up/Down Arrow keys. When on a folder, press the Right Arrow key to expand it. When inside a folder, press the Left Arrow key to jump to the folder.  Items in the Content list can be copied and pasted into Arrangement View content lanes, Session clip slots, and Device chains, depending on the type of content.

If Browser Preview is enabled (under Options > Browser File Preview), content with a preview will play when selected. If it’s not enabled, then press the Right Arrow key to hear a preview, if available.

Ableton offers these in-depth help and learning resources: